以文本方式查看主题

-  计算机科学论坛  (http://bbs.xml.org.cn/index.asp)
--  『 C/C++编程思想 』  (http://bbs.xml.org.cn/list.asp?boardid=61)
----  求助:一个很短的程序,请高手帮帮忙!  (http://bbs.xml.org.cn/dispbbs.asp?boardid=61&rootid=&id=46273)


--  作者:jollyzlj
--  发布时间:4/30/2007 3:14:00 PM

--  求助:一个很短的程序,请高手帮帮忙!
题目是这样的:Hangover
Time Limit:1000MS  Memory Limit:10000K
Total Submit:20182 Accepted:9081

Description
How far can you make a stack of cards overhang a table? If you have one card, you can create a maximum overhang of half a card length. (We're assuming that the cards must be perpendicular to the table.) With two cards you can make the top card overhang the bottom one by half a card length, and the bottom one overhang the table by a third of a card length, for a total maximum overhang of 1/2 + 1/3 = 5/6 card lengths. In general you can make n cards overhang by 1/2 + 1/3 + 1/4 + ... + 1/(n + 1) card lengths, where the top card overhangs the second by 1/2, the second overhangs tha third by 1/3, the third overhangs the fourth by 1/4, etc., and the bottom card overhangs the table by 1/(n + 1).

Input
The input consists of one or more test cases, followed by a line containing the number 0.00 that signals the end of the input. Each test case is a single line containing a positive floating-point number c whose value is at least 0.01 and at most 5.20; c will contain exactly three digits.

Output
For each test case, output the minimum number of cards necessary to achieve an overhang of at least c card lengths. Use the exact output format shown in the examples.

Sample Input


1.00
3.71
0.04
5.19
0.00


Sample Output


3 card(s)
61 card(s)
1 card(s)
273 card(s)

Source
Mid-Central USA 2001


我写的是:
#include<stdio.h>


main()
{
float c,sum=0.5;int j=1;
scanf("%f",&c);
while(sum<c)
{
  j++;
  sum+=1.0/(j+1);
}
printf("\n%d",j);
getch();
}
不知道为什么总是不能通过,说是超时。真搞不懂。


--  作者:zjm.xp@tom.com.cn
--  发布时间:4/30/2007 3:24:00 PM

--  

这位朋友,你好!你这程序我搞不懂,但可以帮我解答一个疑问吗,
网页中的超链接属于都柏林中定义的资源不?
如果要评估信息的质量,从元数据入手行不?


W 3 C h i n a ( since 2003 ) 旗 下 站 点
苏ICP备05006046号《全国人大常委会关于维护互联网安全的决定》《计算机信息网络国际联网安全保护管理办法》
54.688ms