新书推介:《语义网技术体系》
作者:瞿裕忠,胡伟,程龚
   XML论坛     W3CHINA.ORG讨论区     计算机科学论坛     SOAChina论坛     Blog     开放翻译计划     新浪微博  
 
  • 首页
  • 登录
  • 注册
  • 软件下载
  • 资料下载
  • 核心成员
  • 帮助
  •   Add to Google

    >> 本版讨论高级C/C++编程、代码重构(Refactoring)、极限编程(XP)、泛型编程等话题
    [返回] 计算机科学论坛计算机技术与应用『 C/C++编程思想 』 → 求助:一个很短的程序,请高手帮帮忙! 查看新帖用户列表

      发表一个新主题  发表一个新投票  回复主题  (订阅本版) 您是本帖的第 2977 个阅读者浏览上一篇主题  刷新本主题   树形显示贴子 浏览下一篇主题
     * 贴子主题: 求助:一个很短的程序,请高手帮帮忙! 举报  打印  推荐  IE收藏夹 
       本主题类别:     
     jollyzlj 帅哥哟,离线,有人找我吗?
      
      
      等级:大一新生
      文章:0
      积分:52
      门派:XML.ORG.CN
      注册:2007/4/30

    姓名:(无权查看)
    城市:(无权查看)
    院校:(无权查看)
    给jollyzlj发送一个短消息 把jollyzlj加入好友 查看jollyzlj的个人资料 搜索jollyzlj在『 C/C++编程思想 』的所有贴子 引用回复这个贴子 回复这个贴子 查看jollyzlj的博客楼主
    发贴心情 求助:一个很短的程序,请高手帮帮忙!

    题目是这样的:Hangover
    Time Limit:1000MS  Memory Limit:10000K
    Total Submit:20182 Accepted:9081

    Description
    How far can you make a stack of cards overhang a table? If you have one card, you can create a maximum overhang of half a card length. (We're assuming that the cards must be perpendicular to the table.) With two cards you can make the top card overhang the bottom one by half a card length, and the bottom one overhang the table by a third of a card length, for a total maximum overhang of 1/2 + 1/3 = 5/6 card lengths. In general you can make n cards overhang by 1/2 + 1/3 + 1/4 + ... + 1/(n + 1) card lengths, where the top card overhangs the second by 1/2, the second overhangs tha third by 1/3, the third overhangs the fourth by 1/4, etc., and the bottom card overhangs the table by 1/(n + 1).

    Input
    The input consists of one or more test cases, followed by a line containing the number 0.00 that signals the end of the input. Each test case is a single line containing a positive floating-point number c whose value is at least 0.01 and at most 5.20; c will contain exactly three digits.

    Output
    For each test case, output the minimum number of cards necessary to achieve an overhang of at least c card lengths. Use the exact output format shown in the examples.

    Sample Input


    1.00
    3.71
    0.04
    5.19
    0.00


    Sample Output


    3 card(s)
    61 card(s)
    1 card(s)
    273 card(s)

    Source
    Mid-Central USA 2001


    我写的是:
    #include<stdio.h>


    main()
    {
    float c,sum=0.5;int j=1;
    scanf("%f",&c);
    while(sum<c)
    {
      j++;
      sum+=1.0/(j+1);
    }
    printf("\n%d",j);
    getch();
    }
    不知道为什么总是不能通过,说是超时。真搞不懂。


       收藏   分享  
    顶(0)
      




    点击查看用户来源及管理<br>发贴IP:*.*.*.* 2007/4/30 15:14:00
     
     zjm.xp@tom.com.cn 帅哥哟,离线,有人找我吗?
      
      
      等级:大一新生
      文章:6
      积分:77
      门派:XML.ORG.CN
      注册:2007/4/29

    姓名:(无权查看)
    城市:(无权查看)
    院校:(无权查看)
    给zjm.xp@tom.com.cn发送一个短消息 把zjm.xp@tom.com.cn加入好友 查看zjm.xp@tom.com.cn的个人资料 搜索zjm.xp@tom.com.cn在『 C/C++编程思想 』的所有贴子 引用回复这个贴子 回复这个贴子 查看zjm.xp@tom.com.cn的博客2
    发贴心情 

    这位朋友,你好!你这程序我搞不懂,但可以帮我解答一个疑问吗,
    网页中的超链接属于都柏林中定义的资源不?
    如果要评估信息的质量,从元数据入手行不?

    点击查看用户来源及管理<br>发贴IP:*.*.*.* 2007/4/30 15:24:00
     
     GoogleAdSense
      
      
      等级:大一新生
      文章:1
      积分:50
      门派:无门无派
      院校:未填写
      注册:2007-01-01
    给Google AdSense发送一个短消息 把Google AdSense加入好友 查看Google AdSense的个人资料 搜索Google AdSense在『 C/C++编程思想 』的所有贴子 访问Google AdSense的主页 引用回复这个贴子 回复这个贴子 查看Google AdSense的博客广告
    2024/11/22 23:57:53

    本主题贴数2,分页: [1]

    管理选项修改tag | 锁定 | 解锁 | 提升 | 删除 | 移动 | 固顶 | 总固顶 | 奖励 | 惩罚 | 发布公告
    W3C Contributing Supporter! W 3 C h i n a ( since 2003 ) 旗 下 站 点
    苏ICP备05006046号《全国人大常委会关于维护互联网安全的决定》《计算机信息网络国际联网安全保护管理办法》
    62.500ms